Page tree
Skip to end of metadata
Go to start of metadata

Данная статья применима к:

Описание проблемы

При установке обновлений:

ограничивается работа системы электронной подписи (СЭП) при использовании пакета firefox-esr.

Версии firefox-esr:

Проверить установленную  в системе версию пакета firefox-esr можно командой:

apt policy firefox-esr

Предотвращение возникновения проблемы

Если в системе установлен пакет firefox-esr версии 52.6.0esr-1~deb9u1, то перед установкой обновления выполнить команду для запрета обновления пакета firefox-esr:

sudo apt-mark hold firefox-esr

Устранение проблемы

Если (после установки обновления) в системе установлен firefox-esr версий 52.9.0esr-1~deb8u1.elbrus30 или 52.9.0esr-1~deb8u1.elbrus30astra1, то:

  1. Подключить репозиторий установочного диска;
  2. Обновить кеш пакетов:

    sudo apt update

  3. Выполнить команду для установки версии 52.6.0esr-1~deb9u1 пакета firefox-esr c установочного диска:

    sudo apt install firefox-esr=52.6.0esr-1~deb9u1

  4. После установки версии 52.6.0esr-1~deb9u1 пакета firefox-esr заблокировать его обновления:

    sudo apt-mark hold firefox-esr

  5. В дальнейшем, после устранения ограничений, для обновления пакета отменить блокировку обновлений:

    sudo apt-mark unhold firefox-esr

  • No labels