Содержание

Skip to end of metadata
Go to start of metadata

Данная статья применима к:

  • ОС ОН Орел 2.12.40
  • ОС СН Смоленск 1.6 с установленными обновлениями безопасности

О программе

Графическая утилита «Редактор репозиториев» предназначена для создания и управления репозиториями и позволяет выполнять следующие действия:

  • создание репозиториев;
  • открытие репозиториев;
  • редактирование репозиториев;
  • удаление репозиториев;
  • добавление пакетов в репозиторий;
  • удаление пакетов из репозитория;
  • проверка зависимостей пакетов;
  • подпись пакетов для замкнутой программной среды (ЗПС).
  • публикация репозиториев;

Рисунки ниже приведены для информации. Вид окон программы может изменяться в зависимости от версии данной графической утилиты.

Установка программы

Для релиза ОС ОН Орел 2.12.40 и выше:

  • через терминал - ввести команду fly-admin-repo и нажать <Enter>.

Для релиза Смоленск 1.6 с установленным обновлением безопасности №6:

  • загрузить и установить два пакета из репозитория Орел: пакет fly-admin-repo и пакет libflyadminpackage. Пакеты можно загрузить с помощбю web-браузера или использовать приведенный ниже возможный сценарий загрузки (при использовании сценария для загрузки пакетов может понадобится установить пакеты wget  и ca-certificates):

    После загрузки файлов содержащиеся в них пакеты могут быть установлены командой:

    sudo apt install ./fly-admin-repo_0.3.5_amd64.deb ./libflyadminpackage_0.2.3_amd64.deb

    При установке может выдаваться предупреждение, которое можно игнорировать:
    N: Загрузка выполняется от лица суперпользователя без ограничений песочницы, так как файл «/tmp/tmp.moYxt2CZ5h/libflyadminpackage_0.2.3_amd64.deb» недоступен для пользователя «_apt». - pkgAcquire::Run (13: Отказано в доступе)

Запуск программы

Программа может быть запущена:

    • через графический интерфейс: «Пуск - Утилиты - Редактор репозиториев» (см. рис. 1);


Рис. 1 


  • через терминал: ввести команду fly-admin-repo и нажать <Enter>.

Главное окно программы представлено на рис. 2.


Рис. 2 


Если программа запускается не в первый раз, и если ранее на момент завершения программы был открыт репозиторий, то при повторном запуске этот репозиторий будет открыт автоматически.



Создание репозитория

Новый репозиторий можно создать одним из следующих способов:

  • на панели инструментов главного окна программы нажать на кнопку [Создать репозиторий];
  • через пункт меню «Файл - Создать репозиторий»;
  • нажать сочетание клавиш <Ctrl+N>.

Откроется окно «Создание репозитория» (рис. 3).


Рис. 3 


В этом окне доступны для заполнения следующие поля:


  • «Путь» - путь к каталогу, в котором будет локально храниться репозиторий;
  • «Название» - название репозитория (имя каталога, в котором будут располагаться файлы репозитория);
  • «Кодовое имя» - кодовое имя репозитория (название релиза ОС). Значение выбирается из выпадающего списка либо вводится вручную;
  • «Ветка» - название ветки репозитория. Значение выбирается из выпадающего списка либо вводится вручную;
  • «Версия» - номер версии репозитория;
  • «Архитектуры» - архитектуры, с которыми совместимы пакеты репозитория. Значения выбираются из выпадающего списка либо вводятся вручную;
  • «Компоненты» - компоненты репозитория. Значения выбираются из выпадающего списка либо вводятся вручную.

Также можно установить флаг в поле «Подписать репозиторий (apt)», если требуется подписать репозиторий для ЗПС ключом GPG.

Чтобы создать репозиторий, следует нажать кнопку [Да]. Чтобы отменить создание репозитория, следует нажать кнопку [Отмена].

Созданный репозиторий появится в списке репозиториев в левой части главного окна, а в правой части отобразится информация о нем (рис. 4).


Рис. 4 


Открытие репозитория

Открытие существующего репозитория производится одним из следующих способов:


  • на панели инструментов главного окна программы нажать на кнопку [Открыть репозиторий];
  • через пункт меню «Файл - Открыть репозиторий»;
  • нажать сочетание клавиш <Ctrl+O>.

Откроется окно «Выберите папку репозитория» (рис. 5), в котором следует выбрать каталог с нужным репозиторием и нажать кнопку [Открыть].


Рис. 5 


Открытый репозиторий отобразится в главном окне программы.



Редактирование репозитория

Можно выполнять редактирование только текущего открытого репозитория, поэтому для редактирования репозитория предварительно требуется открыть его в программе.

Чтобы отредактировать существующий репозиторий, следует на панели инструментов главного окна программы нажать на кнопку [Изменить репозиторий] либо выбрать пункт меню «Правка -- Изменить репозиторий».

Откроется окно «Изменение репозитория», аналогичное окну «Создание репозитория» (рис. 3), за исключением того, что поле «Кодовое имя» нельзя редактировать.

В открытом окне следует внести необходимые изменения, затем нажать на кнопку [Да] для сохранения изменений и возврата в главное окно. Для возврата в главное окно без сохранения изменений следует нажать на кнопку [Нет].



Удаление репозитория

Чтобы удалить репозиторий, открытый в данный момент, следует в главном окне программы нажать на кнопку [Удалить репозиторий] либо выбрать пункт меню «Файл - Удалить репозиторий».

Откроется диалоговое окно подтверждения (рис. 6). Чтобы подтвердить удаление репозитория, следует нажать на кнопку [Да], чтобы отменить - на кнопку [Нет].


Рис. 6 

Добавление пакета в репозиторий

Добавить новый пакет можно одним из трех способов:


  • в главном окне программы нажать на кнопку [Добавить пакет(ы)];
  • через пункт меню «Правка - Добавить пакет(ы)»;
  • нажать сочетание клавиш <Ctrl+A>.

Сначала откроется окно «Настройки добавления пакетов» (рис. 7).


Рис. 7 


В данном окне следует выбрать из выпадающего списка компонент, к которому будет относиться пакет.

Если добавляемый пакет нужно подписать ключом GPG, следует установить флаг «Подписать пакет для замкнутой программной среды».

Чтобы данное диалоговое окно больше не выводилось при добавлении новых пакетов, следует снять флаг «Показывать диалог при добавлении пакетов».

Выбрав нужные параметры, следует нажать кнопку [Да] для продолжения.

Откроется окно «Добавление пакетов» (рис. 8).


Рис. 8 


В этом окне следует выбрать один пакет или более для добавления и нажать на кнопку [Открыть].

Добавленные пакеты отобразятся в левой части главного окна утилиты. В правой части отобразится информация о выбранном пакете на двух вкладках:


    • «Общие» (рис. 9) - содержит следующую информацию:
    • «Пакет» - имя пакета; «Версия» - номер версии пакета; «Сопровождающий» - ответственный за поддержку пакета разработчик; «Компонент» - компонент, к которому относится пакет; «Подпись (ЗПС)» - присутствует ли подпись для ЗПС; «Описание» - общая информация о функциях пакета.


Рис. 9 


    • «Зависимости» (рис. 10) - содержит список зависимостей.

Рис. 10 



Изменить настройки добавления пакетов можно нажатием на кнопку [Настройки добавления пакетов] либо выбрав пункт меню «Настройки - Настройки добавления пакетов». При этом откроется окно «Настройки добавления пакетов» (рис. 7).



Удаление пакета из репозитория

Чтобы удалить один пакет или более, следует выбрать пакеты в левой части окна, после чего выполнить одно из следующих действий:


  • в главном окне программы нажать на кнопку [Удалить пакет(ы)];
  • выбрать пункт меню «Правка - Удалить пакет(ы)»;
  • нажать сочетание клавиш <Ctrl+D>.

Откроется диалоговое окно подтверждения (рис. 11).


Рис. 11 


Для удаления пакета(ов) следует нажать кнопку [Да]. Для отмены удаления - кнопку [Нет].



Проверка зависимостей пакета

Чтобы проверить зависимости одного или более пакета, следует в главном окне программы выбрать нужные пакеты из списка, после чего выполнить проверку одним из способов:


  • нажать на кнопку [Проверить зависимости];
  • выбрать пункт меню «Файл - Проверить зависимости»;
  • перейти на вкладку «Зависимости» в правой части окна и нажать кнопку «Проверить зависимости».

По завершении проверки в строке состояния главного окна программы появится надпись «Зависимости проверены» (рис. 12).


Рис. 12 


Пакеты, зависимости которых удовлетворены (все нужные пакеты присутствуют в репозитории), отмечаются в левой части окна зеленым кружком на соответствующих им иконках. Пакеты, зависимости которых были нарушены, отмечаются красным кружком. При этом, если выбрать такой пакет, то во вкладке «Зависимости» в правой части отсутствующие пакеты также будут отмечены красным кружком (рис. 13).


Рис. 13 

Подпись пакета для ЗПС

Чтобы подписать один пакет или более ключом GPG, следует выбрать нужные пакеты из списка и нажать на кнопку [Подписать пакет(ы) для ЗПС] либо выбрать пункт меню «Правка - Подписать пакет(ы) для ЗПС».

Откроется окно «Выберите ключ для подписи (ЗПС)». Необходимо выбрать ключ из выпадающего списка. Если в списке нет ни одного ключа, необходимо добавить ключ с помощью утилиты «Управление ключами - KGpg» (kgpg), которую можно запустить нажатием на кнопку «Запустить KGpg».

Выбрав требуемый ключ из списка, следует нажать [Да]. При нажатии на кнопку [Нет] произойдет отмена операции и возврат в главное окно программы.



Добавление репозитория в список локальных источников

Чтобы добавить репозиторий в список локальных источников (файл «sources.list»), необходимо на панели инструментов главного окна программы нажать на кнопку [Добавить репозиторий в список локальных источников].

Откроется окно аутентификации (рис. 14), где необходимо ввести пароль администратора и нажать на кнопку [Да].


Рис. 14 


Добавление репозитория в «sources.list» обозначается сменой на кнопке синего знака «+» на красный знак «-» (рис. 15).


Рис. 15 


Чтобы удалить репозиторий из списка локальных источников, необходимо повторно нажать на кнопку, ввести пароль в окне аутентификации и подтвердить операцию, при этом на кнопке красный знак <<->> сменится на синий знак <<+>>.



Публикация репозитория

Прежде чем опубликовать репозиторий, необходимо выставить настройки публикации. Для этого следует выбрать репозиторий в левой части главного окна и перейти на вкладку «Публикация» в правой части (рис. 16).



Рис. 16 


Доступны следующие настройки:


  • «Доверенный репозиторий» - установка данного флага означает, что репозиторий будет считаться доверенным;
  • «Тип сервера» - «local», «HTTP», «FTP».
  • «IP адрес» - доступен только для типов сервера «HTTP» и «FTP».
  • «Номер порта» - доступен только для типов сервера «HTTP» и «FTP».

В текстовом поле ниже приведена строка репозитория в файле «sources.list». Строка изменяется в зависимости от выбранных настроек. Кнопка справа от строки позволяет скопировать строку в буфер обмена.

Выбрав нужные настройки, следует нажать на кнопку [Опубликовать].



Настройки добавления пакетов

Откроется окно «Настройки добавления пакетов» (см. «Добавление пакета в репозиторий»).



Настройка параметров программы

Для изменения параметров программы следует нажать на кнопку [Параметры] либо выбрать пункт меню «Параметры».

Откроется окно «Параметры» (рис. 17).


Рис. 17 


Доступны следующие настройки:


  • «Показывать версию пакета» - если в этом поле установлен флаг, то в списке пакетов репозитория после имени пакета также будет отображаться его версия;
  • «Ключ для подписи пакетов (ЗПС)» - ключ GPG, используемый по умолчанию для подписи пакетов. Если список ключей пустой, необходимо создать ключ с помощью утилиты «Управление ключами - KGpg». Открыть утилиту можно непосредственно из окна «Параметры», нажав на кнопку [Запустить KGpg].
  • No labels