Содержание

Skip to end of metadata
Go to start of metadata

В ОС СН Смоленск 1.6 с установленным 5-ым обновлением безопасности БЮЛЛЕТЕНЬ № 20200327SE16 и ОС ОН Орёл 2.12 поддерживается подпись и проверка подписи opendocument форматов файлов на алгоритмах ГОСТ 2001-го и 2012-го годов (последний -- в исполнении с ключами длиной 256 бит).

Для подписания файлов opendocument используются программы, входящие в состав LibreOffice. При стандартной установке ОС Astra Linux эти программы устанавливаются по умолчанию. Если они не были установлены, то установить их можно командой:

sudo apt install libreoffice libreoffice-l10n-ru


Данная статья применима к

Установка ПО КриптоПРО

  1. Скачать с сайта КриптоПро, распаковать и установить 64-битный дистрибутив КриптоПро CSP 5. Распаковать дистрибутив после скачивания можно командой:

    tar xzf linux-amd64_deb.tgz

    Для загрузки СКЗИ требуется регистрация на сайте.

  2. Для установки ПО КриптоПРО выполнить команды

    cd linux-amd64_deb
    sudo ./install-gui.sh
    (предполагается, что дистрибутив распакован в текущем каталоге).

    После выполнения второй команды запустится установщик КриптоПРО. В установщике КриптоПРО:

    1. Выбрать «Next» (нажать клавишу «Enter»);
    2. Отметить все пункты, кроме «КС2 Cryptographic Service Provider»
    3. Выбрать «Next» (нажать клавишу «Enter»);
    4. Выбрать «Install» (нажать клавишу «Enter»);
    5. Дождаться сообщения об успешном завершении установки и нажать клавишу «Enter»;
    6.  При наличии лицензии выбрать «Enter the license now» и ввести её, или выбрать пункт «Later» для тестовых целей;
    7. Выбрать «Exit» (нажать клавишу «Enter»);



Установка сертификатов в хранилище КриптоПро



Нажмите меню "Пуск" → меню "Утилиты" → "Инструменты  КриптоПро"


Далее в приложении следует  выбрать меню "Контейнеры" , выделить нужный считыватель и нажать кнопку "Установить сертификат". После чего, приложение оповестит нас о том, что сертификат успешно установлен.



Импорт сертификатов в FireFox


    1. Через меню Firefox

      «Настройки» → «Приватность и защита» → «Устройства защиты» → «Загрузить»

      добавить в список библиотеку

      /opt/cprocsp/lib/amd64/libcppkcs11.so

      после чего перезапустить Firefox. 



    2.  После выполнения предыдущих шагов в меню Firefox следует перейти в «Настройки» → «Приватность и защита» → «Просмотр сертификатов»

      1. В секции "Ваши сертификаты" теперь должны отображаться сертификаты, которыми будут подписываться документы;

      2. В секции "Центры сертификации"  следует импортировать корневые сертификаты, до которых будет строиться цепочка доверия при проверке и создании подписи. 

        В данном примере это будут сертификаты:

        Головной удостоверяющий центр

        Минкомсвязь России

        LLC «CryptoPro GOST Root CA»

        Для каждого центра сертификации, которому вы хотите доверять, необходимо нажать "Изменить доверие".

        В появившемся окне следует выбрать все степени доверия:

Для отображения Вашего личного сертификата в секции "Ваши сертификаты", контейнер с парой ключей и сертификатом должен быть подключен к ОС.

MIME-типы и расширения


Mime-типы и расширения файлов, которые можно подписать с помощью LibreOffice и СКЗИ КриптоПро:

Вид документаMIME-типРасширение
Текстовый документapplication/vnd.oasis.opendocument.textodt
Текстовый документ, используемый как шаблонapplication/vnd.oasis.opendocument.text-templateott
Графический документapplication/vnd.oasis.opendocument.graphicsodg
Графический документ, используемый как шаблонapplication/vnd.oasis.opendocument.graphics-templateotg
Документ презентацииapplication/vnd.oasis.opendocument.presentationodp
Документ презентации, используемый как шаблонapplication/vnd.oasis.opendocument.presentation-templateotp
Электронная таблицаapplication/vnd.oasis.opendocument.spreadsheetods
Электронная таблица, используемая как шаблонapplication/vnd.oasis.opendocument.spreadsheet-templateots
Документ диаграммыapplication/vnd.oasis.opendocument.chartodc
Документ диаграммы, используемый как шаблонapplication/vnd.oasis.opendocument.chart-templateotc
Документ изображенияapplication/vnd.oasis.opendocument.imageodi
Документ изображения, используемый как шаблонapplication/vnd.oasis.opendocument.image-templateoti
Документ формулыapplication/vnd.oasis.opendocument.formulaodf
Документ формулы, используемый как шаблонapplication/vnd.oasis.opendocument.formula-templateotf
Составной текстовый документapplication/vnd.oasis.opendocument.text-masterodm
Текстовый документ, используемый как шаблон для HTML-документовapplication/vnd.oasis.opendocument.text-weboth
Portable Document Format PDFapplication/pdfpdf

Подписание ODF документов 


    Для примера будет использоваться ПО "Текст LibreOffice"
  1. Запустить текстовый редактор LibreOffice:

    "Пуск" — "Офис" — "Текст LibreOffice"
  2. Открыть нужный *.odt документ

    1. перейти в меню

      "Файл" — "Цифровые подписи" — "Цифровые подписи..."
    2. Нажать кнопку «Подписать документ...»;

    3. В открывшемся окне следует выбрать нужный сертификат и нажать кнопку «Подписать»;


    4.  Нажать кнопку «Закрыть»

    5. В результате на экране появится сообщение, что подпись верна.



 В случае возникновения ошибки:

a) "Подпись верна, но невозможно проверить сертификат"

Следует доустановить необходимую цепочку сертификатов (сертификаты УЦ), как описано в главе по "импорту сертификатов в firefox"

б) "Подпись была верна, но документ изменён"

Означает, что документ был изменен и нужно еще раз подписать документ. В ином случае все подписи будут удалены.

  • No labels